More Docker Issues

  • I am trying to install Plex using Docker/Portainer. When I go look at Docker it says it says 'installed and not running.' If I try to restart it I get the following error:


    500 - Internal Server Error Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export LANGUAGE=; echo "Restarting docker ..." && systemctl restart docker.service ': Restarting docker ...


    If I go into Portainer and click 'install' it says 'Docker not installed.'


    Not sure what to do. I did try a reinstall of omv-extras from the CLI but same thing is happening. Any insight would be greatly appreciated.

  • Well now I am in even worse shape lol. I tried the above and now my NAS is offline after the reboot. I can't even get to it through SSH. Locally at the NAS it says it cant boot from local FS. Looks like I am going to have to reinstall OMV from scratch.

  • Sorry for the delay in response. I had to reinstall OMV6 from the ISO. My NAS is an AMD64.


    It says Docker is installed and running. I attempted to install Portainer through OMV and get the following:


    Docker storage :: /var/lib/docker
    Agent port:: 8000
    Web port:: 9000
    Yacht port:: 8001
    ee:: 0
    image:: portainer/portainer-ce
    Enable TLS:: 0
    arch :: amd64
    option :: portainer
    state :: install
    extras :: 6.1.1
    DNS OK.
    Removing portainer ...
    portainer
    Removing portainer/portainer-ce image ...
    Untagged: portainer/portainer-ce:latest
    Untagged: portainer/portainer-ce@sha256:9fa1ec78b4e29d83593cf9720674b72829c9cdc0db7083a962bc30e64e27f64e
    Deleted: sha256:a87d51c7a32408ba63e65888d023ad7d4328fd575d8a4c8bd8cffa495fcd055c
    Deleted: sha256:87236e19ee2522bbbae4893d3beab041038c54d734048d2cef40e9f1604be6f0
    Deleted: sha256:e4aef121959c6207895170b26493d0239b81a54c8e2a26857398adcb0958aa2b
    Deleted: sha256:e0a46f5d05e1b93a7993c45aaea39729d111d7a096e02ac1656c721e39cb5222
    Deleted: sha256:8c004456aeb58b75f792fa091b194c20d6ed4f0d95dd25b0150d71c5c9ab601b
    Pulling portainer/portainer-ce ...
    Using default tag: latest
    latest: Pulling from portainer/portainer-ce
    772227786281: Pulling fs layer
    96fd13befc87: Pulling fs layer
    b733663f020c: Pulling fs layer
    9fbfa87be55d: Pulling fs layer
    9fbfa87be55d: Waiting
    96fd13befc87: Download complete
    772227786281: Download complete
    9fbfa87be55d: Verifying Checksum
    9fbfa87be55d: Download complete
    772227786281: Pull complete
    96fd13befc87: Pull complete
    b733663f020c: Verifying Checksum
    b733663f020c: Download complete
    b733663f020c: Pull complete
    9fbfa87be55d: Pull complete
    Digest: sha256:9fa1ec78b4e29d83593cf9720674b72829c9cdc0db7083a962bc30e64e27f64e
    Status: Downloaded newer image for portainer/portainer-ce:latest
    docker.io/portainer/portainer-ce:latest
    Starting portainer/portainer-ce ...
    040fa6c2f7c3b5b351a64e17e4524eda9dc780f38e367d2307fc7ccdddce0808
    Something went wrong trying to pull and start portainer ...

    END OF LINE


    If I run docker pull portainer/portainer-ce (in Wetty, within OMV) I get


    Using default tag: latest

    latest: Pulling from portainer/portainer-ce

    Digest: sha256:9fa1ec78b4e29d83593cf9720674b72829c9cdc0db7083a962bc30e64e27f64e

    Status: Image is up to date for portainer/portainer-ce:latest

    docker.io/portainer/portainer-ce:latest


    Of course if I click on 'Open web' it fails to open the UI. I am really not sure how to proceed. I do appreciate the help.

  • Did the same thing. NAS won't boot and it looks like another reinstall / rebuild. Clearly that doesn't work for me. I appreciate the efforts.

  • Did the same thing. NAS won't boot and it looks like another reinstall / rebuild. Clearly that doesn't work for me. I appreciate the efforts.

    When you are doing the apparmor patch are you executing it corretly?


    Each line in that codebox that starts with a number is a separate caommand but line 2 wraps around because it is longer than the codebox allowed.


    Here are the lines not in a code box.


    sudo mkdir -p /etc/default/grub.d

    echo 'GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT apparmor=0"' | sudo tee /etc/default/grub.d/apparmor.cfg

    sudo update-grub

    sudo reboot


    Essentially all this is doing is writing a text file called apparmor.cfg that contains the 'GRUB_CMDLINE....' portion, then telling grub to re-configure itself (update-grub), using the text in that file to disable an apparmor boot flag.


    I have applied it to multiple machines over the last few weeks, all intel/amd based systems of varying ages with different hardware configurations without a problem.

  • Did the same thing. NAS won't boot and it looks like another reinstall / rebuild. Clearly that doesn't work for me. I appreciate the efforts.

    You're making a mistake somewhere because there is no way that fix can render a machine non-bootable.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • When you are executing the commands, do they all execute before the reboot or is this kernel panic happening before the reboot?


    Are you executing the commands as a restricted user or as a root/superuser?


    Because of the nature of the commands, every system I have done I have wither logged in as root or issued an su - from a restricted user shell first to become root.


    I also notice that you are on the 6.0 debian kernel. If I recall correctly, the 6.0 kernel had some issues with KVM if you are running it, so it was recommended to go to an earlier kernel or use one of the proxmox kernels available in the kernel plugin. Personally, I would recommend the 6.1.10 proxmox one, as it is newer and seems to be working fine for me.


    Incidentally, it is possible to reverse this grub/apparmor patch by changing the apparmor=0 to apparmor=1. and re-issuing update-grub and reboot. In your situation, since you are having a kernel/boot issue it would probably require booting from a live cd/usb like systemrescuecd (I always install this as a boot option in the kernel plugin, but you can download it and boot from usb or cd made from the download). Personally, I have never done an update-grub like this to repair another drive, there are people here that may be able to direct you better or a little google search should reveal instructions fairly quickly.


    Might be easier and faster than continuously reinstalling OMV while trying to figure this out.


    ***EDIT***

    ....or perhaps the boot-repair-disk as an easier option if the grub repair utility that is on it works.

    boot-repair-disk
    Download boot-repair-disk for free. A rescue disk that includes the Boot Repair tool. See http://sourceforge.net/p/boot-repair-cd/home
    sourceforge.net

  • All good info! Thank you very much. I'm working today but will take another shot at it when I get a chance. To answer your questions, I was executing it as a root user without the sudo command. The commands do execute before the reboot and then the kernel panic happens at the reboot. It is remotely located in the basement so based on when the disconnect occurs and what is on the screen when I get down there, it is after the reboot.

  • I'm guessing the only way to install the proxmox kernel with OMV 6 is through OMV-extras, once the system is back up and running?

  • So I have everything back up and running. I have the proxmox kernel running (6.1.10) and I am still having the same issues with Docker/Portainer. I intend to try the apparmor fix tomorrow after backing up the boot drive and also creating a rescue boot disk.


    Thanks for the help thus far.

  • no sweat, If you are backing up the system drive, in the kernel plugin you can install clonezilla and then set the system to reboot into it once. It makes a great full drive snapshot that can be restored in minutes

  • I should have asked also, what is your hardware configuration? You mentiond AMD64, but just trying to get an idea of models of motherboard & CPU to see if we are talking a standard setup or something odd.


    I know this is all about trying to get your docker working, but If this comes down to a situation that points to some strange issue on your system that has no obvious fix, I have 2 other suggestions.


    #1 if you installed from the OMV ISO, can you try using the debian net install and OMV install script. I have noticed that there are differences in the way these 2 install methods do things. I had one machine a while ago that would not install from the OMV ISO, but would from a net install and OMV install script. If you are going to give this a try, make sure to disable everything except the SSH and standard system utilities in the software selection step of the net install.

    Installing Debian via the Internet

    GitHub - OpenMediaVault-Plugin-Developers/installScript: script that installs omv-extras and openmediavault if not installed already.
    script that installs omv-extras and openmediavault if not installed already. - GitHub - OpenMediaVault-Plugin-Developers/installScript: script that installs…
    github.com


    #2 If all else fails, you could use KVM to run a linux VM that is used as a docker server.

  • I am using a Cisco NSS-324 which is a rebranded QNAP 459. I am booting from an external SSD. I couldn't get the firmware updated so I bailed and went OMV. Good info on the Clonezilla in the kernel. Thank you.

  • IT WORKED!! Thank you all so much. I think it was the combination of the kernel change and the apparmor changes combined. I never would have gotten there without your help. I was loaded for bear with a OS backup and a boot rescue disk ready to go. Definitely will do a backup before anything else.


    Thanks again OMV gurus! :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!