[HOWTO] Instal ZFS-Plugin & use ZFS on OMV

  • My use of the ZFS plugin is for home use and I haven't noticed any instability so far. Having said that, I used the plugin initially and also use the terminal a lot. I like a GUI but also frequent the command line. You could use Webmin to create cron jobs if you prefer a GUI and smile sweetly at the devs to add this feature in the plugin ;-)


    More on cron jobs with Webmin here: http://doxfer.webmin.com/Webmin/Scheduled_Cron_Jobs

  • Just out of curiosity, why is the webmin cron job setup (which I have used) easier than the OMV scheduled tasks?

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • And webmin is no gui? :-P


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!


    I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.

  • Hi,


    I am trying to install ZFS on a new install. Ive downloaded the latest from the site and installed it and all of the updates (my version goes from 1.9 to 1.16 during the update process??) Ive then installed OMV-extras and when ever I try to tick the ZFS and ZFS testing options and click 'save' the boxes uncheck themselves and nothing is installed. Ive also tried downloading the latest openmediavault-zfs.deb file but when I try to install that it tells me it requries debian-zfs which is not avaliable. Any ideas what Im doing wrong? Im sure that is what I did a couple of months ago.

  • There is another problem with the ZFS on 1.16 extra after installing the pluging (thanks for the bug fix):


    When I clicked ZFS on left column, I get a prompt about "Failed to load ZFS module stack.Load the module manually by running 'insmod /zfs.ko'" (not exact wording, because I fixed the problem later so I couldn't get back original message :P )


    Running "find / -name zfs.ko" returns nothing, trying to make ZFS myself under /usr/src/zfs-0.6.3 and I was warned that "This will break ZFS", ok....


    Trying to re-install zfs-dkms, I get the below error:


    OK.....I checked that "spl-dkms" is also installed, weird.....


    Then I looked around on internet, I found something insteresting: Some people realized that spl-dkms has to be configured before zfs-dkms, so I tried following:



    Looks promosing, to verify.....


    Code
    root@openmediavault:~# find / -name zfs.ko
    /var/lib/dkms/zfs/0.6.3/3.16.0-0.bpo.4-amd64/x86_64/module/zfs.ko
    /lib/modules/3.16.0-0.bpo.4-amd64/updates/dkms/zfs.ko


    Bravo! Now I won't get any error when clicking into ZFS in GUI.
    Will this be addressed in the installer?

  • It is an issue that only happens on select systems. Because we don't create the zfs packages, it is difficult to fix for every system.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Great work.


    After using Freenas (had problems with some plugins), Openmediavault and Xpenology i have reinstalled openmediavault.
    Due to a power outage my system chrashed under Xpenology.
    One drive stopped working and Xpenology didn't boot anymore.
    Tried to restore the SHR partition within Linux but
    Had problems repairing the SHR partition and also my backup drive was corrupted.
    So a lot of data loss. :(


    Due to the broken drive i am now using 3x 2TB drives.
    and 1 system drive with a backup partition for important files.
    I have formatted it to Raid 5 but prefer Raid-Z1.
    Is it wise and save to use, and will there be still support in the future?

  • @thespeed I know that you're a drive down because of the issues you've had with Xpenology, but just some friendly input to stop you suffering further data loss -


    If you can, if/when you move to ZFS, choose RAIDZ2 as a minimum or just mirror the drives - this will of course mean a 50% space loss if mirrored, or indeed the same with 4 drives in a RAIDZ2 (and does rely on replacing the drive). However, RAIDZ1 only allows for 1 drive to fail for the array to still function. Whilst this might seem like it isn't an issue because you'd just shut the array down and replace the drive, it is not unheard of for the resilvering than takes place afterwards to kill a second drive (or even a third).


    This is obviously dependent on drive age and health, but being that you have suffered data loss already, unless you are backing up everything in the RAID on to another disk in its entirety, you need to be prepared that you may suffer more loss.


    Most of us who have used RAIDZ1 have learnt this the hard way and its a horrible horrible feeling.


    Also, you may want to take the time now to give your drives a full check over using SMART and a drive utility.


    Just my opinions. :-)


    Sorry one last thing, even using RAIDZ2 or 3 is not fool proof. Backups are the key ;-)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!