Error when try to pull image

    • OMV 4.x
    • Resolved
    • Error when try to pull image

      Hi there,

      Building a new NAS, with clean install OMV4 (in Legacy mode). For those interested, take a look here

      So fresh install, updated and installed OMV-Extras. Now when I try to pull an image I get "Failed to read file '/tmp/bgstatusrQ71Ej' (size=0)."






      Tried many times: here are two Error messages, trying to pull same image:

      • Failed to read file '/tmp/bgstatusrQ71Ej' (size=0).
      Fout #0:
      OMV\Exception: Failed to read file '/tmp/bgstatusrQ71Ej' (size=0). in /usr/share/php/openmediavault/json/file.inc:207
      Stack trace:
      #0 /usr/share/php/openmediavault/json/file.inc(223): OMV\Json\File->getContents()
      #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(340): OMV\Json\File->read()
      #2 /usr/share/openmediavault/engined/rpc/docker.inc(262): OMV\Rpc\ServiceAbstract->finalizeBgProcStatus('/tmp/bgstatusrQ...', '', Object(OMV\Exception))
      #3 [internal function]: OMVRpcServiceDocker->pullImage(Array, Array)
      #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      #5 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('pullImage', Array, Array)
      #6 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Docker', 'pullImage', Array, Array, 1)
      #7 {main}

      • Failed to read file '/tmp/bgstatusItIVVN' (size=0).
      Fout #0:
      OMV\Exception: Failed to read file '/tmp/bgstatusItIVVN' (size=0). in /usr/share/php/openmediavault/json/file.inc:207
      Stack trace:
      #0 /usr/share/php/openmediavault/json/file.inc(223): OMV\Json\File->getContents()
      #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(340): OMV\Json\File->read()
      #2 /usr/share/openmediavault/engined/rpc/docker.inc(262): OMV\Rpc\ServiceAbstract->finalizeBgProcStatus('/tmp/bgstatusIt...', '', Object(OMV\Exception))
      #3 [internal function]: OMVRpcServiceDocker->pullImage(Array, Array)
      #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      #5 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('pullImage', Array, Array)
      #6 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Docker', 'pullImage', Array, Array, 1)
      #7 {main}


      The thread mentioned above might give some insight in this matter...
      Can someone please point me in the right direction for solution? Thanks in advance!
      Files
      2 x ODROID-HC2, both with 2TB running OMV4
      1 x Intel Atom N330 (D945GCLF2) with 2 x 1,5TB running OMV4

      The post was edited 1 time, last by sm0ke ().

    • Are you on the latest version? This error should not occur anymore since many versions.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Yes, latest omv4 image, clean install and updated. And installed omv-extras.Also tried clean install without updating omv, installed omv-extras. Same issue (after updated omv completely (kernel included).
      2 x ODROID-HC2, both with 2TB running OMV4
      1 x Intel Atom N330 (D945GCLF2) with 2 x 1,5TB running OMV4
    • I fear you can not do anything right at the moment. You hit a bug caused by a race condition. I will open a bug issue for the Docker plugin. You need to wait until the plugin developer has fixed it.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • votdev wrote:

      I fear you can not do anything right at the moment. You hit a bug caused by a race condition. I will open a bug issue for the Docker plugin. You need to wait until the plugin developer has fixed it.

      ryecoaaron wrote:

      This is fixed in the latest release of the plugin.

      Big Thanks to you guys and of course the developers/maintainers of Docker!!!
      Everything seems to work fine, I now can proceed witch my installation/configuration of OMV :)
      Cheers!
      2 x ODROID-HC2, both with 2TB running OMV4
      1 x Intel Atom N330 (D945GCLF2) with 2 x 1,5TB running OMV4
    • No expert, but my advice:

      Update system (especially Docker), but would recommend update all. Maybe make backup before updating, depending on situation.
      When you're just setting up or did fresh install, update all.

      If that doesn't fix your problem, I think more info is needed (OMV version, running on armhf? and log-files maybe).
      2 x ODROID-HC2, both with 2TB running OMV4
      1 x Intel Atom N330 (D945GCLF2) with 2 x 1,5TB running OMV4
    • Omv 4 on raspberry 4 updated all and issue still exist, Tried pulling other images prompted me error too

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; docker pull 'docker pull haugene/transmission-openvpn:latest'' with exit code '1':omv 4 running on raspberry 4. Updated omv and docker.


      Error #0: OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; docker pull 'docker pull haugene/transmission-openvpn:latest'' with exit code '1': in /usr/share/openmediavault/engined/rpc/docker.inc:250 Stack trace: #0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMVRpcServiceDocker->{closure}('/tmp/bgstatus5m...', '/tmp/bgoutputBt...') #1 /usr/share/openmediavault/engined/rpc/docker.inc(254): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure)) #2 [internal function]: OMVRpcServiceDocker->pullImage(Array, Array) #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array) #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('pullImage', Array, Array) #5 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Docker', 'pullImage', Array, Array, 1) #6 {main}

      The post was edited 2 times, last by Sharifin ().

    • geaves wrote:

      Sharifin wrote:

      haugene/transmission-openvpn:latest
      There is the error for the Pi you need to specify haugene/transmission-openvpn:latest-armhf if you don't add a tag the plugin uses :latest by default.
      still getting the same error after specifying armhf. Even other images that i tried to pull prompts the same error msg. I tried downloading from docker image repo in webui, it works other than that when i try to pull image doesnt work

      The post was edited 1 time, last by Sharifin ().