[HOWTO] Downgrade to version 3.0.13 after accidentally upgrading to newer version (breaking things)

  • As many others I'm guessing, I accidentally upgraded to version 3.0.15 from 3.0.13. This resulted into a non working omv installation and the uninstallation of a lot of extras plugins. I've successfully reverted back to 3.0.13. Because I think it can be helpfull for others I'll explain how to do this.


    1. SSH into your OpenMediaVault machine as root
    2. Run the following commands one by one:


    cd /tmp
    apt-get install php-json-schema
    wget http://packages.openmediavault.org/public/pool/main/o/openmediavault/openmediavault_3.0.13_all.deb
    dpkg -i ./openmediavault_3.0.13_all.deb
    service openmediavault restart


    3. Login into OpenMediaVault via the web interface. If you've had OMV-Extra's plugins installed they won't be listed under services anymore.
    4. Reinstall your plugins via the 'Plugins' tab, or install them from terminal using:


    apt-get install openmediavault-yourplugin1 openmediavault-yourplugin2


    5. The configuration of the plugins will still be there but you might have to disable/enable the plugins to get them fully functional again. I had to do this with openmediavault-mysql to get the web-management interface working again.



    That's all. No need to panic :).
    Hope this helps!

  • Thank you so much for that howto!
    Works perfect for me.


    I must also Disable/enable my Nginx and mysql to get it work again.


    btw. al little correction

    Code
    apt-get install apt-get install php-json-schema


    must be


    Code
    apt-get install php-json-schema
  • root@hp-proliant:/tmp# service openmediavault restart
    Failed to restart openmediavault.service: Unit openmediavault.service failed to load: No such file or directory.




    and if i call the webgui:







    Failed to connect to socket: No such file or directory


    Failed to connect to socket: No such file or directory


    Fehler #7001:
    exception 'OMVException' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc.inc:135
    Stack trace:
    #0 /usr/share/php/openmediavault/rpcproxy.inc(125): OMVRpc::exec('Services', 'getStatus', Array, Array, 3)
    #1 /var/www/openmediavault/rpc.php(32): OMVJsonRpcProxy->handle()
    #2 {main}

    HP-Proliant Microserver Gen8 | omv = always latest | 64 bit | 1x3TB ,3x4TB , 1x500GB HDD for Boot | omvextrasorg = latest | HP P212| Plugins = NUT, HWRaid, luksencryption OMV extras

  • I told people over and over and over not to use OMV 3 and that a big update was coming that would cause issues... I don't want to read about anyone asking when the plugins will be ready. As Volker says, they will be ready when they are ready.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Note Openmediavault 3.x - Important Information!


    Leaving this thread open for you guys to discuss.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Thx for that little kind of impression, where to look.


    I had to remove openmediavault-nut as well, to reactivate webif.


    Afterwards i flagged openmediavault as hold 3.0.13. Does someone know, how to get omv-nut, -backup, -usbbkp to work with 3.0.13 again?


    regards,
    Erik.

  • Noch eine Lösung wo bei mir funktioniert hat:


    schaut mal unter /var/log/apt/history.log nach, bei der installation von 3.15 wurden pakete entfernt, diese Pakete wieder über ssh nachinstallieren ( mit abhängigkeiten)


    jetzt kann ich wieder auf die Weboberfläche zugreifen :thumbsup:

  • Afterwards i flagged openmediavault as hold 3.0.13.


    Good idea. I also did it this way with the following commands now:


    apt-mark hold openmediavault
    apt-get update


    Check the flagged packages with this command:


    apt-mark showhold


    and with these commands you are able to upgrade the openmediavault package again:


    apt-mark unhold openmediavault
    apt-get update


    Noch eine Lösung wo bei mir funktioniert hat:


    schaut mal unter /var/log/apt/history.log nach, bei der installation von 3.15 wurden pakete entfernt, diese Pakete wieder über ssh nachinstallieren ( mit abhängigkeiten)


    jetzt kann ich wieder auf die Weboberfläche zugreifen


    And now you are able to use openmdiavault 3.0.13 again or openmediavault 3.0.15? Which packages were removed?


    Greetings Hoppel

    ---------------------------------------------------------------------------------------------------------------
    frontend software - tvos | android tv | libreelec | win10 | kodi krypton
    frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
    -------------------------------------------
    backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8
    ---------------------------------------------------------------------------------------------------------------------------------------

    Edited 4 times, last by hoppel118 ().

  • yes i'm able to use my omv again with 3.13


    The removed packages of my installation was:


    Start-Date: 2016-04-24 11:57:38
    Commandline: apt-get --yes --force-yes --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::=--force-confold install openmediavault
    Upgrade: openmediavault:amd64 (3.0.13, 3.0.15)
    Remove: php-json-schema:amd64 (0.2.0), libchm1:amd64 (0.40a-3+b1), python-dbus:amd64 (1.2.0-2+b3), libdbus-glib-1-2:amd64 (0.102-1), php5-sqlite:amd64 (5.6.19+dfsg-0+deb8u1), libblas-common:amd64 (1.2.20110419-10), libqt4-xml:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), python-support:amd64 (1.0.15), libqt4-network:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libatk1.0-0:amd64 (2.14.0-1), openmediavault-calibre:amd64 (3.1), python-django-common:amd64 (1.7.7-1+deb8u4), qtchooser:amd64 (47-gd2b7997-2), libqt4-sql:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), python-cssutils:amd64 (0.9.10-1), python-pkg-resources:amd64 (5.5.1-1), libblas3:amd64 (1.2.20110419-10), libwebpmux1:amd64 (0.4.1-1.2+b2), qdbus:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), python-numpy:amd64 (1.8.2-2), openmediavault-autoshutdown:amd64 (3.0.6), libgstreamer-plugins-base1.0-0:amd64 (1.4.4-2), libqtcore4:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), python-qt4:amd64 (4.11.2+dfsg-1), libwebpdemux1:amd64 (0.4.1-1.2+b2), python-pypdf:amd64 (1.13-2), python-pil:amd64 (2.6.1-2+deb8u2), libqt4-svg:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libqt4-dbus:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libxcursor1:amd64 (1.1.14-1+b1), libqt4-xmlpatterns:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libqt4-opengl:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libsctp1:amd64 (1.0.16+dfsg-2), libwebp5:amd64 (0.4.1-1.2+b2), libqtassistantclient4:amd64 (4.6.3-6), dbconfig-common:amd64 (1.8.47+nmu3+deb8u1), libqtwebkit4:amd64 (2.3.4.dfsg-3), libqt4-script:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), tzdata-java:amd64 (2016c-0+deb8u1), mywebsql:amd64 (3.6-omv4), python-gobject:amd64 (3.14.0-1), python-imaging:amd64 (2.6.1-2+deb8u2), fping:amd64 (3.10-2), liblapack3:amd64 (3.5.0-4), python-dbus-dev:amd64 (1.2.0-2), libpoppler-glib8:amd64 (0.26.5-2), python-beautifulsoup:amd64 (3.2.1-1), libxt6:amd64 (1.1.4-1+b1), libgtk2.0-common:amd64 (2.24.25-3+deb8u1), libpoppler46:amd64 (0.26.5-2), php5:amd64 (5.6.19+dfsg-0+deb8u1), libatk1.0-data:amd64 (2.14.0-1), python-mechanize:amd64 (0.2.5-3), python-dateutil:amd64 (2.2-2), libaudio2:amd64 (1.9.4-3), python-psutil:amd64 (2.1.1-1+b1), openmediavault-mysql:amd64 (3.0.2), openmediavault-shellinabox:amd64 (3.3), openjdk-7-jre-headless:amd64 (7u95-2.6.4-1~deb8u1), python-cairo:amd64 (1.8.8-1+b2), libmtp9:amd64 (1.1.8-1+b1), ca-certificates-java:amd64 (20140324), libmng1:amd64 (1.0.10+dfsg-3.1+b3), libpodofo0.9.0:amd64 (0.9.0-1.2+b2), python-lxml:amd64 (3.4.0-1), python-apsw:amd64 (3.8.6-r1-1), libqt4-designer:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), qtcore4-l10n:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libqtdbus4:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), python-django:amd64 (1.7.7-1+deb8u4), python-sip:amd64 (4.16.4+dfsg-1), python-six:amd64 (1.8.0-1), shellinabox:amd64 (2.19), python-poppler:amd64 (0.12.1-8.1), sysstat:amd64 (11.0.1-1), libgtk2.0-0:amd64 (2.24.25-3+deb8u1), openmediavault-nginx:amd64 (3.0.3), python-gobject-2:amd64 (2.28.6-12+b1), libqt4-test:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), php5-mysqlnd:amd64 (5.6.19+dfsg-0+deb8u1), libmtp-common:amd64 (1.1.8-1), libgfortran3:amd64 (4.9.2-10), python-netifaces:amd64 (0.10.4-0.1), libgstreamer1.0-0:amd64 (1.4.4-2), python-chm:amd64 (0.8.4.1-1), libqt4-scripttools:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libxinerama1:amd64 (1.1.3-1+b1), php5-pgsql:amd64 (5.6.19+dfsg-0+deb8u1), java-common:amd64 (0.52), libxcomposite1:amd64 (0.4.4-1), python-gtk2:amd64 (2.24.0-4), openmediavault-jdownloader:amd64 (3.1), libqtgui4:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), python-django-tagging:amd64 (0.3.1-4), libxrandr2:amd64 (1.4.2-1+b1), libqt4-declarative:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libqt4-help:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libpodofo-utils:amd64 (0.9.0-1.2+b2)
    End-Date: 2016-04-24 11:57:55



    remove 3.0.15 and install 3.0.13, then install all removed packages again

  • yes i'm able to use my omv again with 3.13


    OK, I thought you were able to use omv 3.0.15. ;)

    ---------------------------------------------------------------------------------------------------------------
    frontend software - tvos | android tv | libreelec | win10 | kodi krypton
    frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
    -------------------------------------------
    backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8
    ---------------------------------------------------------------------------------------------------------------------------------------

    Edited 3 times, last by hoppel118 ().

  • After downgrading as described above I'm not able to log in, got


    "Failed to connect to socket: No such file or directory"


    What can I do?


    You need to delete all your plugging using CLI.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!