Upgrade Debian 9 and 4.x

  • I changed the two lines on weakref.py and it did help for a while. But since OMV 4..0.16 I am having these two issues when running apt update and apt upgrade. Openmediavault package is not properly updated.



  • You have a typo in your changed code.

  • Hi, I have OMV 4.1.4, and still got this error after apt-get update:

    Code
    Hit:23 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docker stretch Release
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f2675ffa730>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f2675ffa730>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable

    Shouldn't it be fixed? Or do I need to manually edit the line?

    Intel G4400 - Asrock H170M Pro4S - 8GB ram - Be Quiet Pure Power 11 400 CM - Nanoxia Deep Silence 4 - 6TB Seagate Ironwolf - RAIDZ1 3x10TB WD - OMV 5 - Proxmox Kernel

  • If you search the forum, there is a thread about this and how to fix if you want. Otherwise, it is harmless.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • upgrade worked but now NFS is failing.
    Error #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'nfs-kernel-server' 2>&1' with exit code '1': A dependency job for nfs-server.service failed. See 'journalctl -xe' for details. in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)#1 /usr/share/php/openmediavault/system/systemctl.inc(104): OMV\System\SystemCtl->exec('start', NULL, false)#2 /usr/share/openmediavault/engined/module/nfs.inc(71): OMV\System\SystemCtl->enable(true)#3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleNfs->startService()#4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatus4X...', '/tmp/bgoutputTp...')#8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)#12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#14 {main}

  • Hello,


    After the distrib upgrade (omv 3 --> omv4) i have this error (cf screenshot) i have try the solution of @Wolf2000 but no changes, i have an another message error ...


    can you help me?


    Thanks



    EDIT : I don't understand the text of message of wolf, sorry for this message (if you can delete this please delete :) )

  • Hi, I have OMV 4.1.4, and still got this error after apt-get update:

    Code
    Hit:23 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docker stretch Release
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f2675ffa730>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f2675ffa730>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable

    Shouldn't it be fixed? Or do I need to manually edit the line?

    I have just upgrade OMV and I am having the same error. Also, the webgui is toasted. I use debian 9 stretch. I've tried the "reinstall"commmand and no luck. All the shares are working, thank god, but the webgui is not. Is this something related to Debian?
    prior to the update, everything was working fine. Now when I try to open the server from the browser, all I get is an "apache" page.


    How can I give you more info to get help?

  • I have just upgrade OMV and I am having the same error.

    Everyone does until you fix it. It is a bug in the python package from the Debian repos.


    All the shares are working, thank god, but the webgui is not. Is this something related to Debian?
    Now when I try to open the server from the browser, all I get is an "apache" page.

    Since OMV uses nginx, this is your problem. remove the apache packages.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Everyone does until you fix it. It is a bug in the python package from the Debian repos.

    Since OMV uses nginx, this is your problem. remove the apache packages.

    I've read a lot about editing this and that. Bot I am newbie. I can acces the server using putty and also remote desktop from windows. What should I do?

  • I just did a complete fresh install 4.13 and then upgraded to 4.17 still when running a apt-get update i was getting the weakref.py error, fixed it by editing the file again but i found it very strange that that bug is still there

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!