Shared Folders

  • The only way to mount the folders in /sharedfolders for me currently is to modify the
    /etc/systemd/system/sharedfolders-xxx.mount
    here is an example:


    from:


    Description=Mount shared folder MOD to /sharedfolders/MOD
    DefaultDependencies=no
    After=zfs-mount.service
    Conflicts=umount.target
    RequiresMountsFor=/srv/91080aad-6550-4341-9d5e-72bc444afebf/
    AssertPathIsDirectory=/srv/91080aad-6550-4341-9d5e-72bc444afebf/MOD/
    AssertPathIsDirectory=/sharedfolders
    AssertPathIsMountPoint=/srv/91080aad-6550-4341-9d5e-72bc444afebf/




    to


    Description=Mount shared folder MOD to /sharedfolders/MOD
    DefaultDependencies=no
    After=zfs-mount.service
    Conflicts=umount.target
    RequiresMountsFor=/srv/91080aad-6550-4341-9d5e-72bc444afebf/
    #AssertPathIsDirectory=/srv/91080aad-6550-4341-9d5e-72bc444afebf/MOD/
    AssertPathIsDirectory=/sharedfolders
    AssertPathIsMountPoint=/srv/91080aad-6550-4341-9d5e-72bc444afebf/



    I don't know if it's the right way but up until now it's the only one I found working.

  • can you highlited changes?. i can't see changes.

  • I think the initial approach from @votdev was to add this line After=fuse-xxx.service', but I don´t know for what 'xxx' stands.


    /etc/systemd/system/sharedfolders-xxx.mount:


    Description=Mount shared folder MOD to /sharedfolders/MOD
    DefaultDependencies=no
    After=zfs-mount.service
    After=fuse-xxx.service
    Conflicts=umount.target
    RequiresMountsFor=/srv/91080aad-6550-4341-9d5e-72bc444afebf/
    AssertPathIsDirectory=/srv/91080aad-6550-4341-9d5e-72bc444afebf/MOD/
    AssertPathIsDirectory=/sharedfolders
    AssertPathIsMountPoint=/srv/91080aad-6550-4341-9d5e-72bc444afebf/

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • can you highlited changes?. i can't see changes.

    The change is in red adding a # to comment out AssertPathIsDirectory this is fine but the file is auto generated so if there is an update the file may have to changed again.


    The best option from that thread was to use the wait-for script.


  • I really do not understand why commenting out 'AssertPathIsDirectory=/srv/91080aad-6550-4341-9d5e-72bc444afebf/MOD/' fixes the issue. /MOD/ is a directory within the filesystem that is mounted to '/srv/91080aad-6550-4341-9d5e-72bc444afebf'. If the filesystem is mounted, then the directory MUST exist also. Systemd is waiting for the filesystem to be mounted based on the 'RequiresMountsFor' line, the 'AssertPathIsMountPoint' makes sure the directory is a mount point, so why the hell does the directory within that filesystem not exist.


    Until this behaviour is not clear i do not want to change the current auto-generated mount unit because from a technical point of view everything is OK.


    Please move this discussion into the bugtracker, the forum is not the best place to track this issue.

  • I can confirm that works :thumbup:


    /sharedfolders will populate using megerfs but you have to wait and for users having dockers linked to /sharedfolders that was a problem.


    To ensure and test, my /sharefolders were populated, a reboot brought them back up empty, added that line to one share on my fuse mount, saved, rebooted, and /sharedfolders/<share-name> is populated.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!