docker cannot run mldonkey

  • i follow this step forum.openmediavault.org/index…light=mldonkey#post167683
    but when i create it and run, mldonkey restart forever.
    log show:Read-only file system for directory /var/lib/mldonkey? so i change “MLDONKEY_DIR”,and then mldonkey can running. but i cannot call IP:4080. also cannot find the port(4080) is running.
    0.png1.png3.png4.png5.png6.png


    docker run \
    -d \
    --name mlnet \
    --restart=unless-stopped \
    -e PGID=100 \
    -e PUID=1001 \
    -v /sharedfolders/mldonkey/config:/var/lib/mldonkey:rw \
    -v /sharedfolders/mldonkey/tmp:/mnt/mldonkey_tmp:rw \
    -v /sharedfolders/mldonkey/completed:/mnt/mldonkey_completed:rw \
    -p 4000:4000 \
    -p 4001:4001 \
    -p 4080:4080 \
    -p 20562:20562 \
    -p 20566:20566/udp \
    -p 16965:16965 \
    -p 16965:16965/udp \
    -p 6209:6209 \
    -p 6209:6209/udp \
    -p 6881:6881 \
    -p 6882:6882 \
    -p 3617:3617/udp \
    -p 4444:4444 \
    -p 4444:4444/udp \
    logicwar/mldonkey

  • Well... The permissions you're showing in the console, and the permissions you give the container, are two different things.


    Look in your container settings again (the one with the host path/container paths)... You have that green trigger under "R/O" enabled next to your paths. R/O, means Read Only. Edit the share and turn that trigger off, then restart the container and you should be good I would think (I don't use mldonkey)

  • Well... The permissions you're showing in the console, and the permissions you give the container, are two different things.


    Look in your container settings again (the one with the host path/container paths)... You have that green trigger under "R/O" enabled next to your paths. R/O, means Read Only. Edit the share and turn that trigger off, then restart the container and you should be good I would think (I don't use mldonkey)

    i am sorry to report you answer when i donnot know how to replay you...
    i closed R/O,the mldonkey is running normal. thanks
    but http://IP:4080 also cannot connect, and show info:


    403 Forbidden


    Connection from 192.168.0.111 rejected (see downloads.ini, allowed_ips)



    MLDonkey/3.1.5 at 172.17.0.4 Port 4080
    192.168.0.111 is my pc IP, when i add the IP in downloads.ini(allowed_ips), also cannot connect. when i restart mldonkey, downloads.ini file is restore


    By the way,i use mldonkey because i want to download "ed2k://"。 Any good suggestions?


    my god,i delete the running mldonkey,and then delete config files. at last run command agian, http://ip:4080 is conneted... i guess modify method cannot useful,run command is ok

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!