Can't update OMV on Odroid HC2

  • I have some trouble when trying to update OMV.


    Looking at similar issues on the forum led me to the conclusion, that it might have something to do with the way OMV connects to the internet, or more specific a DNS issue.

    I have tried some of the suggestions in the other threads, but no luck so far.

    The timestamp of OMV was off even though I have activated NTP server. I managed to get the time right again, but that did not help either.

    I have tried pinging 8.8.8.8 and it goes through, but google.com does not.


    I’m running OMV 5.5.6-1 (Usul) on a Odroid HC2.


    Some of the errors I'm getting are these:


    When I try to open ‘armbian-config’ I get the following message:

    Warning: Configuration cannot work properly without a working internet connection. Press CTRL C to stop or any key to ignore and continue.


    The apt-get update command gives these error messages:

    If I try to update Portainer in OMV-Extras I get this error:

    Code
    Docker storage :: /srv/dev-disk-by-label-NAS/appdata/
    Agent port:: 8000
    Web port:: 9000
    Opt-out :: 1
    arch :: armhf
    option :: portainer
    state :: install
    extras :: 5.3.4
    DNS error. Exiting ...
    Done.

    And the 'Update Management' does not show any updates at all.


    Hope you guys can help.

  • Thanks, but that did not work either.

    I had already tried it with just my router ip as DNS.


    Why is this DNS issue occurring now?

    My system has been running for a year with no problems.



    And for anorther problem!

    It is possible that I have just disabled my ethernet connection ||

    I was fiddeling around looking for a solution, and I think I choose to disable instead of choosing DHCP.

    Is there any way in now?


    My router can see the OMV and it has the normal IP. But I can not connect i any way.

    Can I access the SD card in some way and edit the ethernet connection through there?



    Edit:

    This is what my config.xml shows under Interfaces.

    I can see that method says manual, can I just change it to Static or DHCP in the config file or is there more to it than that?

  • Try


    wget http://packages.openmediavault.org/public/pool/main/o/openmediavault/openmediavault_5.5.11-1_all.deb

    sudo dpkg -i openmediavault/openmediavault_5.5.11-1_all.deb

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ryecoaaron  macom


    Hope you guys is up for a little more of your magic.


    I still can't update OMV.

    I have tried what you suggested and been looking through all the threads that I could find in the forum regrading my problem, and I can see that I'm not the only one. But non of the suggestions given in those works for me.

    OMV5 DNS change

    DNS Problem OMV5


    When I run omv-firstaid and go to configure network interface, this is what I see:

    docker0

    enx001e0636f592 <-- this is my ethernet connection

    veth2e526c6

    veth7cd231c

    vethfc832ac


    Router showing two connections for OMV. One I can use and one I can't


    My /etc/resolv.conf contains nothing at all. However there is a resolv.conf in /etc/resolvconf/run that contains nameserver 1.0.0.1


    The output of ls -al /etc/resolv.conf is this: lrwxrwxrwx 1 root root 32 Dec 29 2019 /etc/resolv.conf -> /run/systemd/resolve/resolv.conf



    And apt-get update results in the following error.

  • When you use omv-firstaid, do you get an error message?

    The output of ls -al /etc/resolv.conf is this: lrwxrwxrwx 1 root root 32 Dec 29 2019 /etc/resolv.conf -> /run/systemd/resolve/resolv.conf

    That is how it is supposed to be.

  • You can try to manually add the nameserver to /etc/resolv.conf

    If I try that through nano resolv.conf I get an error saying 'no such file or directory'.


    I just put the SD in a Linux machine and now the resolv.conf contained the following.

    I added nameserver 192.168.1.1 but still no joy :(

  • Yes but I'm getting this error:

    Code
    [ Error writing /etc/resolv.conf: No such file or directory ]
  • This is the output from systemctl status systemd-resolved.service

  • parallel post You have the llink from /etc/resolve.conf to /run/systemd/resolve/resolv.conf, so that file might be missing.


    nano /run/systemd/resolve/resolv.conf and add the nameserver there.

    Then check

    cat /etc/resolv.conf if the changes are there

  • You have the llink from /etc/resolve.conf to /run/systemd/resolve/resolv.conf, so that file might be missing.


    nano /run/systemd/resolve/resolv.conf and add the nameserver there.

    Then check

    cat /etc/resolv.conf if the changes are there

    That seems to do the trick.

    The output of cat /etc/resolv.conf is now

    Code
    nameserver 1.0.0.1
    nameserver 192.168.1.1

    And I'm now getting updates in the GUI :)


    ls -al /etc/resolv.conf

    Quote

    lrwxrwxrwx 1 root root 32 Dec 29 2019 /etc/resolv.conf -> /run/systemd/resolve/resolv.conf


    Is the there any thing that I should be aware of in the future with this problem?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!