Problem with web login

  • Hi, I'm having problem with my web login as admin. OMV doesn't recognize my password, but if I reboot the system, the password works. I can access the terminal with my own user, also I can access the login with my user, but the dashboard is almost empty. I'm not sure how to solve this since I'm sure the password work but not always. I already upgrade my OMV 5 to last version. Also, I already clear my browser cache and tried with other browsers.

    Thanks

  • I can't help you with why your admin password doesn't work sometimes and works other times.


    Logging into the GUI with a username other than admin will result in an almost empty dashboard. So what you are seeing when you do this is by design unless you take certain steps to add that username to the openmediavault-admin group which you clearly have not done.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • Code
     Error #0:
    OMV\HttpErrorException: Incorrect username or password. in /var/www/openmediavault/rpc/session.inc:151
    Stack trace:
    #0 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #3 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #4 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #5 {main}

    I don't know if help, but i receive this error, and now the password stop working at all.

    One question, can I change the admin password from cli? With sudo -u admin passwd ?

  • Sorry I run sudo -u command and works, but now seems I broke SAMBA

    I can see any folder and change any setting without this error.

  • the rest of the code

  • Clearly today is not my day, I change the password with the su -u admin command without problem, but at that point samba stop working, so I unistall samba from apt, and then reinstall it, now samba doesn't work neither the web GUI.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!