Docker GUI plugin now stable

  • aufs is not available in any of the Debian 4.x kernels.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • so here is what happens if I enable the plugin and set location of docker base path (I just set it to my storage partition)





    then after I click ok on that if I hit apply configuration changes I get the following error.


    this is the error about filesystem not existing.
    Any help would be awesome.
    Again this is a fresh install of OMV 3.


    Thanks.

  • Hello guys,


    thanks for this fantastic plugin. I installed the emby image container and it works really flawless, but I have one little problem. By the way, I am completely new to docker. ;) I want to assign the UID "1002" and GID "100" to the emby user in the docker container.


    So I committed my current emby docker container and assigned it the following UID/GID under environment variables:




    After that I tried to backup the configuration with the "Server Configuration Backup" plugin, but it fails. So i chowned the folder for these backups in the following way:

    Code
    chown 1000:1000 -R /media/backups

    Now, when I try to backup again, it works fine. But UID/GID 1000:1000 is already in use and it would be much work to change my complete system to this default values of the emby container.


    What did I forget or what is wrong?


    Thanks Hoppel

    ---------------------------------------------------------------------------------------------------------------
    frontend software - tvos | android tv | libreelec | win10 | kodi krypton
    frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
    -------------------------------------------
    backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8
    ---------------------------------------------------------------------------------------------------------------------------------------

    Edited once, last by hoppel118 ().

  • @smudgeman
    confirmed, I will fix it
    this problem occur when you change docker base path
    current workaround is
    setting it none and `rm /var/lib/openmediavault/fstab_tasks.json`


    @hoppel118
    what is the name of "Server Configuration Backup" plugin ?
    and what docker container name and repo exactly you used?

    OMV3 on Proxmox
    Intel E3-1245 v5 | 32GB ECC RAM | 4x3TB RAID10 HDD
    omv-zfs | omv-nginx | omv-letsencrypt | omv-openvpn
    Click link for more details

  • Hello luflow,


    thanks for answering.


    @hoppel118what is the name of "Server Configuration Backup" plugin ?
    and what docker container name and repo exactly you used?


    It is exactly that name:



    I activated both repos under omv-extras "docker" and "docker testing" and installed the plugin "openmediavault-docker-gui 3.1.3". After that I pulled the following emby docker image and created my container:



    Greetings Hoppel

    ---------------------------------------------------------------------------------------------------------------
    frontend software - tvos | android tv | libreelec | win10 | kodi krypton
    frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
    -------------------------------------------
    backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8
    ---------------------------------------------------------------------------------------------------------------------------------------

  • I didn't know that it was emby plugin


    anyway
    I tried backup plugin, I cannot make backup at all
    don't know why, can't find source for this plugin
    don't know why 1000:1000 worked in yourcase (was it previous APP_UID APP_GID?, if so try recreating docker container not modifying)


    my suggestion to use network location

    OMV3 on Proxmox
    Intel E3-1245 v5 | 32GB ECC RAM | 4x3TB RAID10 HDD
    omv-zfs | omv-nginx | omv-letsencrypt | omv-openvpn
    Click link for more details

  • Does the "modify" button works OK for all of you? For who answers... do you use OMV in port 80/443 or custom port?


    When I try to save the "Modify" form, it brings me an error: "Error: "Failed to connect to localhost port 80: Connection refused" - Code: 7"

    Finnaly!!! In the latest update,it got fixed!
    Thanks devs!

  • Hey luxflow,


    the uid:1000 and gid:1000 are the default values for the emby container. I found it here under "Technical Information" and "Environment Variables":


    https://hub.docker.com/r/emby/…er/#technical-information


    I chowned a bit to meet 1000:1000. So it works fine for me now.



    Thanks for your help! Greetings Hoppel

    ---------------------------------------------------------------------------------------------------------------
    frontend software - tvos | android tv | libreelec | win10 | kodi krypton
    frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
    -------------------------------------------
    backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8
    ---------------------------------------------------------------------------------------------------------------------------------------

    Edited once, last by hoppel118 ().

  • heres another question....
    In the case of rutorrent docker, if I make changes to the settings like limit download and upload speeds when the container is restarted it did not retain my changes I made but does retain knowledge of the downloads.


    If I hit commit in the plugin section of openmediavault and launch that container it also does not store the changes I made.


    How can I make these changes stick?


    thanks.

  • The image is diameter/rtorrent-rutorrent:stable
    It was pulled from the Docker Image Repo tab.


    https://github.com/diameter/rtorrent-rutorrent/issues/32


    Very cryptic answer, no idea seems to be like that.



    @majorpayne


    There are plenty of answers to this in google, also you can refer to the official docker doc


    https://docs.docker.com/engine…/container-communication/


    containers can communicate via the default bridge and can also share exposed volumes in between each other

  • Hello guys,


    since the last update the docker images repo looks as follows for me. Is this a known issue? What can I do to correct this?



    I use the latest available versions for omv and for docker:





    What is the differnece between these two repos? Which of them should be used? At the moment I activated both. Is this the correct way?




    And a little Feature Request: Is it possible to get the docker service listed in the services view?



    Thanks and greetings Hoppel

    ---------------------------------------------------------------------------------------------------------------
    frontend software - tvos | android tv | libreelec | win10 | kodi krypton
    frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
    -------------------------------------------
    backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8
    ---------------------------------------------------------------------------------------------------------------------------------------

  • How do i change the docker containers from running on my Debain OS HDD? I tried changing it to my AppSSD + docker shared folder but got the following error:


    Version 3.0.64
    Kernel Linux 4.9.0-0.bp0.1-amd64
    Fresh OMV 3.0 Install
    Docker GUI 3.1.4
    Version: 1.13.1
    API version: 1.26
    Go version: go1.7.5


  • All reported bug is fixed in 3.1.5


    openmediavault-docker-gui (3.1.5) stable; urgency=low


    * Fix docker image path
    * Fix getDockerRepo


    -- OpenMediaVault Plugin Developers <plugins@omv-extras.org> Thu, 02 Mar 2017 20:29:38 +0900


    anyone expereince `filesystem... ` error
    try `rm /var/lib/openmediavault/fstab_tasks.json`


    @ryecoaaron will upload soon


    Additional note : I'll be busy for the next 6 months (maybe 1 year), I cannot patch anymore
    maybe other developer help

    OMV3 on Proxmox
    Intel E3-1245 v5 | 32GB ECC RAM | 4x3TB RAID10 HDD
    omv-zfs | omv-nginx | omv-letsencrypt | omv-openvpn
    Click link for more details

    Edited once, last by luxflow ().

  • will upload soon

    Done.


    Additional note : I'll be busy for the next 6 months (maybe 1 year), I cannot patch anymore
    maybe other developer help

    Thanks for all of your work :)

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!