Send Notification througth gmail problem

  • Hi!
    I am trying to use Google mail smtp-server to send all my OMV notifications.
    Bellow is my configuration:


    With following settings:
    SMTP Server: smtp.google.com
    SMTP Port: 587
    Use SSL/TLS: On


    A window pops up when I click on the button "Send a Test Mail" saying it was sent successfully.


    But when I look at the log file /var/log/mal.info it says


    Jul 29 19:43:59 nas postfix/smtp[16154]: warning: relayhost configuration problem
    Jul 29 19:43:59 nas postfix/smtp[16154]: AE17B4CB92: to=<thunderlight1@gmail.com>, relay=none, delay=4780, delays=4775/0.04/5/0, dsn=4.3.5, status=deferred (Host or domain name not found. Name service error for name=smtp.google.com type=AAAA: Host not found)


    I can do a "dig mtp.google.com", so the is no issue resolving the DNS-name.


    cesar@nas:/var/log$ dig smtp.google.com



    ; <<>> DiG 9.9.5-9+deb8u13-Debian <<>> smtp.google.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 60112
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1



    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 1280
    ;; QUESTION SECTION:
    ;smtp.google.com. IN A


    Any suggestion on how to fix this?


    Regards,
    Cesar da Silva

  • Try disabling IPv6 in your network settings.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Hi All,
    Thank you for your all replies.
    I had IPv6 disabled already through the WEB-GUI, so that should not be any issue, if I did not need to disable it in any other way?
    I changed the SMTP server to the mentioned address smtp.googlemail.com and it is working now.
    Problem resolved. Thanks.


    Regards,
    Cesar da Silva

  • Try Less secure apps


    Log in to your Gmail account through a web browser and enable access through less secure apps . Less secure apps can make your account more vulnerable, Google will automatically turn this setting off if it's not being used. However, bypass this security setting with a configuration tweak within your Google Email Account .


    How "more secure apps" help to protect your account?


    • Which level of access you're giving the client before you connect your Account.
    • Client access only a relevant part of your Account, like your email or calendar.
    • Connect your Google Account to the client without exposing your password.
    • Disconnect your Google Account from the client at any time.
  • Nope. Got *.googlemail.com here in germany. But yes, the account is very old...
    And the OP should look at https://www.lifewire.com/what-…ail-smtp-settings-1170854


    HTH

    Thanks for the link! (lifewire)

    I live in MA USA and was able to finally get my OMV notifications working using smtp.gmail.com and port 465 SSL/TLS. I original had it set to 25 or 587 but would not handshake.

    Using 5.3.9-1 (Usul)

    5.3.9-1 (Usul)
    Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
    Linux 5.4.0-0.bpo.3-amd64
    1 M4-CT128M4SSD2 > OMV
    3 x 2TB WD Red (Raid 5)
    1 4TB WD External Drive

  • Thanks for the link! (lifewire)

    I live in MA USA and was able to finally get my OMV notifications working using smtp.gmail.com and port 465 SSL/TLS. I original had it set to 25 or 587 but would not handshake.

    Using 5.3.9-1 (Usul)

    This finally got it to work for me. Thanks!!!

  • This finally got it to work for me. Thanks!!!


    Thanks for the link! (lifewire)

    I live in MA USA and was able to finally get my OMV notifications working using smtp.gmail.com and port 465 SSL/TLS. I original had it set to 25 or 587 but would not handshake.

    Using 5.3.9-1 (Usul)

    Hi,


    I am triyng as well to set email notification on my gmail account, but I still can't do it work, even with your advices...


    Could you send me the screenshot of what you've put into the notification tab on OMV ? What should be the sender and recipient email cases ?


    Thanks for your help!

  • The sender should be the email address you would like to use to send the email. The recipient should be the email address you'd like to get the notification on. They can be the same email address.

  • New user here. I could not for the life of me got this to work until I found this thread. Very useful. I am in the US and the port was different than the two default ones in OMV. I also had to go to Google Account>Security and generated an 16-digit app password.

  • Has anyone Checked their DNS settings in Network? Putting the DNS Server and the Search Domains as my router fixed my issue immediately. Just adding something I learned so that those in the future have something else to consider when trouble shooting this issue

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!