How to enable Flash Memory plugin?

  • Hi,
    I have installed the Flash Memory plugin.
    I followed the instructions, but according to the instructions (point 7) I should enable the plug-in.
    But there is no enable button on the page.


    See picture:


    How can enable it?



    thanks

  • So, how does one verify that it is enabled and running? I can see no indication anywhere.

    There is no service running. It just creates tmpfs mount points. If you really don't believe it is working, look at the output of: mount

    omv 5.5.6 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi I was curious on how to know if flashmem plug-in is working?


    I originally thought I had set it up correctly but when I edited fstab and rebooted it caused my system disk to go read only. I figured out how to repair that and I removed my edits to fstab and the problem went away.


    So possibly two things I don't know is how to tell is if the plug-in is working? And what I did wrong to cause the system disk to have an error and go read only.


    I read that you could tell thru the mount command but I don't know what to look for.there is my mount command return.



    root@server:~# mount
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
    udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=913887,mode=755)
    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
    tmpfs on /run type tmpfs (rw,nosuid,relatime,size=1481324k,mode=755)
    /dev/sdg1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
    pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
    cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
    cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
    tmpfs on /etc/machine-id type tmpfs (ro,relatime,size=1481324k,mode=755)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=23,pgrp=1,timeout=300,minproto=5,maxproto=5,direct,pipe_ino=11288)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
    tmpfs on /tmp type tmpfs (rw,relatime)
    /dev/md0 on /srv/dev-disk-by-label-server type ext4 (rw,noexec,relatime,stripe=384,data=ordered,jqfmt=vfsv0,usrjquota=aquota.user,grpjquota=aquota.group)
    /dev/md0 on /sftp/RobertR728/servertv type ext4 (rw,noexec,relatime,stripe=384,data=ordered,jqfmt=vfsv0,usrjquota=aquota.user,grpjquota=aquota.group)
    /dev/sdg1 on /var/folder2ram/var/log type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/log type tmpfs (rw,nosuid,nodev,noexec,relatime)
    /dev/sdg1 on /var/folder2ram/var/tmp type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/tmp type tmpfs (rw,nosuid,nodev,noexec,relatime)
    /dev/sdg1 on /var/folder2ram/var/lib/openmediavault/rrd type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/lib/openmediavault/rrd type tmpfs (rw,nosuid,nodev,noexec,relatime)
    /dev/sdg1 on /var/folder2ram/var/spool type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/spool type tmpfs (rw,nosuid,nodev,noexec,relatime)
    /dev/sdg1 on /var/folder2ram/var/lib/rrdcached type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/lib/rrdcached type tmpfs (rw,nosuid,nodev,noexec,relatime)
    /dev/sdg1 on /var/folder2ram/var/lib/monit type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/lib/monit type tmpfs (rw,nosuid,nodev,noexec,relatime)
    /dev/sdg1 on /var/folder2ram/var/lib/php5 type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/lib/php5 type tmpfs (rw,nosuid,nodev,noexec,relatime)
    /dev/sdg1 on /var/folder2ram/var/lib/netatalk/CNID type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/lib/netatalk/CNID type tmpfs (rw,nosuid,nodev,noexec,relatime)
    /dev/sdg1 on /var/folder2ram/var/cache/samba type ext4 (rw,relatime,errors=remount-ro,data=ordered)
    folder2ram on /var/cache/samba type tmpfs (rw,nosuid,nodev,noexec,relatime)root@server:~#

  • The presence of folder2ram entries in your mounts indicate that the Flash Memory plugin is enabled.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I found this helpful:


  • Apologies for hijacking/resurrecting an old thread and thank you in advance for any help!


    I have just installed the flash memory plugin (system drive on SSD) and edited /etc/fstab exactly as per the instructions, rebooted and have a read-only filesystem.


    I have tried mount -o rw, remount / to no avail. I can log in via SSH quite happily, and also into the box directly under my desk. Does it make a difference that I edited fstab as sudo not root (trying to be good and not always SSH in as root!)


    Bright ideas always welcome

  • I've just managed to fix it, thank you for replying. :)


    I added the extra parts as indicated on the flash memory plugin page to fstab which I suspect is what caused the read-only error. Going into recovery mode, editing the configuration and changing the "ro" to "rw" on the line beginning with "linux" unlocked it for edit, undid the changes and voila.


    I didn't realise initially that it wasn't strictly completely necessary to edit fstab for the flashmemory plugin to work. Lesson learned.

  • I've just managed to fix it, thank you for replying.


    I added the extra parts as indicated on the flash memory plugin page to fstab which I suspect is what caused the read-only error. Going into recovery mode, editing the configuration and changing the "ro" to "rw" on the line beginning with "linux" unlocked it for edit, undid the changes and voila.


    I didn't realise initially that it wasn't strictly completely necessary to edit fstab for the flashmemory plugin to work. Lesson learned.

    None of the changes recommend in the flashmemory plugin's info would make the root filesystem mount readonly. Can you post your fstab that causes the issue?

    omv 5.5.6 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • This is my current fstab:

    The only difference was that I added "noatime,nodiratime," to the line starting UUID to make it "UUID=c900083f-700e-0023-b000-fbb000000e32 / ext4 noatime,nodiratime, errors=remount-ro"



    The error I got was parsing line 9, so the section I edited, reverting has fixed it all. I wonder if some misplaced punctuation on that line?

  • What about when using docker images which is stored on SD card, data partition.
    In that case, they have their own log files inside the docker containers.


    Has anyone considered this?

    No because I wouldn't store docker containers on an SD card at all. There is no way the flashmemory plugin could help writes on a container because most people don't have anywhere near enough ram to put the container files in tmpfs. If you are worried about writes with docker containers, you should be telling the docker plugin to use a data drive.

    omv 5.5.6 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!