Samba not working on OMV 4.x while working on OMV3.x

  • Hello,

    I am new and installed initially the OMV3 using the ISO (openmediavault_3.0.86-amd64) and got all my CAMs to work perfectly (at the 1st attempt). As I wanted to install zoneminder etc... I opted to install a Debian 9.2.1 with OMV4 which went all ok. I did the same GUI configuration (and double checked the smb.conf which look the same) but for some reasons my CAMs keep saying:
    "Mounting to NAS server failed. Invalid directory or incorrect user name/password."

    I tried to set log level to 3 but didn't see the logs popping up in /var/log/samba so not sure how to debut and move forward.

    My CAMs are Hikvision and need to have a quota assigned to each directly. I emptyed the directories being shared by SMB to start clean.

    Noted that quota seems wrong (see size of Corridor directory for ex)

    Corridor shows a size not linked to the HD space and over the definedvalue.

    Any idea of the issue? I don't necessary believe that my shares don't work because of this quota stuff but if you have some guidance on how to drill down the issue that would be appreciated.

    I have posted most of the important screens but please ask if anything missing or strange.


    Is there a way to export the OMV3 config and reimport in my Debian with OMV4? maybe that would do the trick quicker.

  • Not sure why but the service is showing red and here are some outputs that may give a hint?

    I did a start and it went back to my initial issue:

    BTW I have succeed to connect from Windows on the shares but I am missing some parameters to ensure that one user can't access another one share.

    At least the config seem exactly the same but this Hikvision cameras are touchy. I believe the issue is not on the OMV4 itself but I don't understant why it worked on OMV3. Trying to reset one camera to see.

    Putting logs to Full i get:

    I have checked several times my pwd but they are the same. Could it be because in my pwd there is the character & ?


  • Interesting reading: Privileges and permissions explained under OMV

    Not sure if the system permissions should still be root:user but then if that's the case then that may be my issue. When i created my share I did select "Recursive".

    Is that then my issue? should i put them back on root:Front for example? or delete the shares and create them again maybe worth :)

    Maybe the smb.conf file can be updated to avoid:
    Nov 20 22:49:19 Debian smbd[20916]: WARNING: The "syslog" option is deprecated
    Nov 20 22:49:19 Debian smbd[20916]: WARNING: The "syslog only" option is deprecated
    Nov 20 22:49:19 Debian smbd[20916]: WARNING: The "null passwords" option is deprecated

    Before the users had only one group and now in OMV4 there is this user group showing up. could this explain the differences? as my initial setup was exactly the same.

    getting lost!

  • Hello,

    I had the same problem after a working OMV3 upgrade to OMV4 with Windows. I added following line to the [global] section in /etc/samba/smb.conf:

    ntlm auth = yes

    after a restart of the smbd everything was fine again.

    Hope this helps

  • Worked for me. Many thanks!

  • I added following line to the [global] section in /etc/samba/smb.conf:

    You shouldn´t edit /etc/samba/smb.conf directly. If you change SMB/CIFS settings in OMV the next time, the smb.conf is overwritten by OMV. You can force this by
    CLI> omv-mkconf samba

    Instead add your entry in the SMB/CIFS settings -> Advanced settings -> Extra options field.

    A second possibility is the add the next line to /etc/default/openmediavault


    Then do a
    CLI> omv-mkconf samba
    CLI> service smbd restart
    You can check your SAMBA settings with
    CLI> testparm

    This is tested for OMV3. I hope it works also for OMV4.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • Hi i have the same prob with my camera on my fresh install of OMV 6, i remember in OMV 4 it worked with this parameter but i don't get it in OMV 6 or maybe i don't do it in the good way?
    If someone could help me

    • Official Post

    If yes the test from the camera get no success, any ideas?

    Did you save and apply?

    You can try to additionally add

    client min protocol = SMB1

    also not sure if it has to be in the global samba extra options or in the extra options of the share.

  • Hi thx for answer, yes save and apply
    I tried in global samba extra option "client min protocol = SMB1" but I got this answer:

    In share extra option no error but it doesn't work

    Maybe you have another tips?

    Best regards

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!