error after docker update in OMV

  • after I updated suddenly docker is out of my plugins and when I want to reinstall it I get this message


    >>> *************** Error ***************
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-docker-gui 2>&1' with exit code '100': Reading package lists...


    Building dependency tree...


    Reading state information...


    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:
    openmediavault-docker-gui : Depends: docker-ce (< 5:18.10) but 5:19.03.0~3-0~debian-stretch is to be installed
    E
    :
    Unable to correct problems, you have held broken packages.


    <<< *************************************


    anybody know how to fix this?

  • The same error happened to me right now.


    I guess the openmediavault-docker-gui does not accept the new docker-ce version.


    I reinstalled the docker-ce package through the terminal, started a container with portainer, and I just manage all my containers with portainer now.


    But I am all ears if someone knows how to make the openmediavault-docker-gui work with docker-ce 5:19.03.0~3-0~debian-stretch.

  • Indeed, I have not installed the new docker-ce package because of this. when using apt upgrade it kept back the upgrade of docker. Upon trying to update via apt install docker-ce it wants to remove openmediavault-docker-gui package. Will not update docker at this time. Will wait for more info.


    Though I use portainer for managing and docker-compose for configuration/managing too.

    NOW:
    Mac mini Late 2012 / macOS Catalina / Docker Desktop for Mac
    Intel Core i7-3615QM CPU @ 2.30GHz - 16GB RAM - 4 external disks via USB3.0 - Gigabit Ethernet - 20 docker containers via docker-compose ;)
    PREVIOUS:
    omv 5.2.1-1 (Usul) - Bevy NUC thanks to TechnoDadLife (NUC5CPYB)
    Celeron N3050 @ 1.60GHz - 8GB RAM - 2 external disks via USB3.0 - Gigabit Ethernet - 21 docker containers via docker-compose :)

  • Happened to me also after a clean install of OMV4. I was going crazy because I didn't know what was happening and why it won't work as before.


    Now that I got it back to the previous version it works again. Just had to run apt-get install docker-ce=5:18.09.8~3-0~debian-stretch

  • I experienced the same problem. Luckily I had a recent back-up (every day an image is created and zipped with a script) and that fixed the issue without any problem. Using the "Update Management" tab in the OMV GUI, the Docker GUI is retained, but the Pi-Hole container crashes every 4.5 to 5 minutes and its GUI becomes unreachable.

  • Hello Everyone,


    My Docker-Gui also after an update is crashed. All docker containers are running as normal.
    docker-gui is already at v4.1.5


    The error is the one below. Any ideas to solve it?


    Error #0:OMV\Rpc\Exception: Invalid RPC response. Please check the syslog for more information. in /usr/share/php/openmediavault/rpc/rpc.inc:186Stack trace:#0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Docker', 'getNetworks', Array, Array, 3)#1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()#2 {main}

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!