Updates - GUI & Root Console

  • Hi everyone,

    First of all I do wish you are all well and managing to keep isolated as best as possible.

    I just did a new install of OMV5 and I had some issues along the way, the system is up and running now but still some issues remain. I am trying to update packages using "apt-get update" and I get a could not resolve packages message.

    I have GUI access but nothing appears/happens when using the Update Management option.

    On the install system would hang on IPv6 and managed to circumnavigate by removing the network cable and also disabling IPv6 in the router.

    I do have an internal IP, looks like I may not be getting out to update the debian packages.

    Would be grateful for any pointers to assist. I also set Date & Time to NTP Server as was suggested elsewhere in Forum.

    Thanks in advance.

  • Thanks again macom,

    cat etc/resolv.conf returned:

    search local


    ping -c 5 returned:

    5 packets transmitted, 5 received, 0% packet loss, time 10ms

    I guess that means in my rookie understanding that we are able to ping outside the LAN?

  • Yes, you have internet connection.

    But there is only one nameserver (DNS server) defined:

    When you added the other two server, did you click save and the apply? Any error messages?

    If you look in the network settings in the GUI of OMV, do still see the three server in there?

    Please post the output of

    ls -al /etc/resolv.conf

    Should be like this

    lrwxrwxrwx 1 root root 32 Jan 4 19:25 /etc/resolv.conf -> /run/systemd/resolve/resolv.conf

    To get it working you can add an additional nameserver manually

    add "nameserver" to the end of /etc/resolv.conf

    systemctl enable systemd-resolved.service

    systemctl start systemd-resolved.service

  • macom,

    Yes, all servers are still within the settings, no issue when saving. Snapshot attached, interestingly no IP is shown on the DHCP field but it is visible on the GUI.


    ls -al /etc/resolv.conf returns:

    -rw-r--r-- 1 root root 36 Mar 26 09:09 /etc/resolv.conf

    The command for adding a manual nameserver is:

    /etc/resolv.conf is this correct?

    Can you elaborate on the other two further commands below please:

    systemctl enable systemd-resolved.service

    systemctl start systemd-resolved.service

    Just for your information and as I think I mentioned in the first post. When I did the initial install, when the install was setting up IPv6 it would hang and not be able to install any further. I disabled IPv6 on my ISP's router, seems no other issues with devices in the house. I tried to set up a virtual machine (laptop) with OMV5.3.9-1 iso. Same thing happened when it gets to IPv6 on the install, it's unable to install further and sits on a blue screen.

    Thanks for the help!

  • The command for adding a manual nameserver is:

    nano /etc/resolv.conf opens nano as editor for the file

    add "nameserver" at the end

    Ctrl +x


    then run the two commands to make the change effective

    systemctl enable systemd-resolved.service

    systemctl start systemd-resolved.service

    Then update the system


    Hopefully it is fixed then.

  • Thanks macom,

    But have no idea how to use nano, being a bit slow here, you'll need to step me through this a little more rookie like if possible... sorry.

    I opened nano and I'm already big time lost, there was something like local name server whatever I did I rebooted and now its not there.

    Any chance you could give me some baby steps please... no idea what your message above means even though how simple it will be.

    Got no idea how to safely exit nano. Sorry for this.

  • Just tried... as I thought... I am stupid

    When I got into nano it said no etc directory exists.

    Then after making changes etc/resolve.conf nameserver1.0.0.1 says no such file or directory

    I have no idea what to do with Nano, as said when I first logged in I'm sure it said:


    Now nothing on login to nano.

    Sorry man, out of my depth here.

  • Twenty of the most frequently found to be useful nano commands are at the bottom of the screen. ^ is the Ctrl key.

    Thanks for the support I'm looking at that too...

    Still got no idea how to manage the interface, if I need spaces, new lines etc.

    Cant be anymore honest than that, even though it's a simple request.

  • nano is a text editor. When you start it you have two choices.

    One is to pass the filename you wish to edit on the commandline:

    nano /etc/resolv.conf

    And yes, spelling counts so double check the filename and path. This will open an existing file for editing, if the file exists. Misspelled files usually do not exist, and if they don't a new file with the misspelled name is opened for editing.

    The other way is to just run nano alone. This will open a file for editing that has no name yet. When you close nano you will be prompted for a filename. I think I mentioned that spelling counts, so be very careful.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Thanks gderf and macom,

    I used nano /etc/resolv.conf from OMV CLI, upon entering nano all I have is a cursor blinking at the top of the page.

    I added the following below to the cursor line:

    nano /etc/resolv.conf nameserver

    Then added the two commands followed by the omv-update.

    It then listed the packages, went to try and fetch them but got on all the counts:

    Could not resolve packages for security.debian, deb.debian, and omv.org

    0 upgraded and 0 installed.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!