Windows 10 Build 1709 and newer can't connect to SMB shares on OMV

  • 1709 Build 17046 (latest) with 2.2.14 absolutely no problems...

    But we don´t know your OMV Version...pls get a signature

    Get a Rose Tattoo...

    HP t5740 with Expansion and USB3, Inateck Case w/ 3TB WD-Green
    OMV 5.5.23-1 Usul i386|4.19.0-9-686-pae

  • 1709 Build 17046 (latest) with 2.2.14 absolutely no problems...

    But we don´t know your OMV Version...pls get a signature

    Strange, I thought for sure that this was my problem since the thread I linked appeared directly on point.

    I'm also running OMV 2.2.14. Build 1709 Windows PC's remain unable to access my OMV, earlier capable.

    I tried to update my OMV to 3. After the update, I lost the web GUI, which just returned a blank page, but otherwise the OMV appeared to be functioning. Unfortunately, SMB problems remained unchanged. Regarding the GUI, I assume it may be because I didn't remove all plugins in advance, which seems like a lot of trouble to go through, as I'm not sure I'll be able to configure things like Syncthing again on the same folders without resyncing.

  • I believe if you manually execute omv-initsystem in the terminal, you should be able to see which plugins are causing a problem. It's been a while since I ran in to this issue though, and that may not be the correct solution.

  • Apparently, Windows 10 Build 1709 deprecated SMB 1.0: https://social.technet.microso…orum=win10itpronetworking

    My PC's running older versions of Windows can continue to access my OMV's SMB shares without issue. The newer build PC's cannot.

    Is there a way to update my OMV to use SMB 2 or 3?

    Disabling smb1 in Windows-Features in Windows 10 1709 helped for me.

    Picture is in german. Sorry for that.

    After, now i can connect my shares.

    *future backup system*
    OMV 3.0.96 (Erasmus) -
    Linux 4.9.0-0.bpo.4-amd64
    Core2Quad Q8200 @2,33 GHz | 6 GB
    Intel SSD 320 40GB System |
    6x2TB WD-Red Raid5

    *replacement under construction*
    OMV 3.0.96 (Erasmus) -
    Linux 4.9.0-0.bpo.4-amd64
    i3-2120 @ 3,30 GHz | 8 GB
    Sandisk SSD 126GB System | 3x6TB WD-Red Raid5

  • One other way is to desable Samba 1 & 2 on the Windows 10 machine

    Running the Powershell as admin and typing

    Set-SmbServerConfiguration -EnableSMB1Protocol $false
    Set-SmbServerConfiguration -EnableSMB2Protocol $false

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!