Help setting up resilio sync docker

  • Hey,
    just stumbled over this thread.
    I just installed this docker a few days ago. I'm also super new to all of this, but I managed after setting up several other docker with @Technodadlife's tutorials.

    This docker is pretty straight forward.
    According to the info page there are only few extra arguments you need.
    I left the docker in bridge mode and did not change the ports.
    As always you need to provide the puid, pgid and the timezone.
    Then you have to think about changing the umask setting. This site helped me figure it out.
    I set mine to 000 (bye bye security ;) ) because in my first test setup I otherwise had issues connecting nextcloud to my sync (nextcloud was not able to write in them).
    After that you set paths to the three folders: /config (for me the Appdata folder like in the other docker tutorials)
    /sync (I created a new shared folder for this)
    /syncdownloads (I just stuck this once in my general data folder)

    After that I ran the rocker and was able to access it via my-internal-ip:8888

    Hope this helps..

  • Hey,
    would you mind to elaborate a bit on your answer? This is the first docker I tried to set up - and failed, because there no "as always".

    I've started with

    docker run -d --restart=unless-stopped --name=resilio \
    -p 8888:8888 \
    -p 55555:55555 \
    -v resilio-config:/mnt/sync \
    -v /srv/dev-disk-by-label-MyHDD/Media:/mnt/data \

    and got stuck there.

    Any help is appreciated!


  • I created my Dockers via the web gui, so I'm not super familiar how to do it using the terminal. I think the info-page tell you about all the necessary commands:

    Regarding the codes you wrote above you need to specify at least your timezone, pgid, puid.
    Also I'm not sure you used the -v arguments correctly (I might be wrong). The info page says:
    -v path-to-folder:/config \
    -v path-to-folder:/sync \
    -v path-to-folder:/downloads \

    Regarding pgid and puid the info page says:

  • Thanks, this helped in the end. I used:

    docker create --restart unless-stopped --name=resilio-sync \
    -e PUID=1003 \
    -e PGID=100 \
    -e TZ=Europe/London \
    -e UMASK_SET=022 \
    -p 8888:8888 \
    -p 55555:55555 \
    -v resilio-config:/config \
    -v /srv/dev-disk-by-label-MyHDD/Media/downloads:/downloads \
    -v /srv/dev-disk-by-label-MyHDD/Media:/sync \

  • I wonder if you'd be able to show a screen shot of your setup?
    I am in particular interested in:
    - the ports (is it Bridge If so, what is the host name?)
    - the volumes (i see there are three, I don't follow and would love to see how that looks and why there are three)

    If you don't mind it would be very helpful

  • I followed the instructions above to setup a resilio sync docker. I got the web gui to show up. However when I look for my NAS folders, I dont see any of my shared folders. All is see is /sync
    I want to use resilio sync to do a IOS camera backup. Please help

  • Thanks Macom!!
    I was able to create a new folder under /sync and backup my files into it.
    Have another question - this is probably to do with permissions in OMV. When i try to delete the backed up files from the newly created folder from windows explorer - I get an access denied - require permissions error.

  • Hi - I have setup resilio on my rpi4 omv5.0 test unit using the following stack. I have my main OMV5 NAS with various drives on another desktop system.

    I can access the resilio webui no problems but I also get same problem. When I click the +standard folder sign and look for my NAS folder, all I see is /sync.

    I then installed resilio windows client on my laptop and tested it out on a sample folder and that works in that when I click on the + standard folder, it allows me to choose any folder on my network (including my main OMV5 NAS) to create a sync. However, this laptop is not always on, so I would like to get it working on my OMV5 NAS test unit where I installed the below stack.

    Can anyone please help?

  • Hello,

    This is normal behavior, Docker applications are "jailed", that's why you have to link volumes.

    If you want more folders to show in Nas, you need to add many volumes as needed :

    - /srv/dev-disk-by-label-Hippo/Music/TestSync:/sync
    - /srv/dev-disk-by-label-Hippo/Movies:/movies
    - /srv/dev-disk-by-label-Hippo/TV:/tv
  • ok but my point is I cant this folder, I have files in there but its not syncing to my phone. when I go to the webui, it does not allow me to get a QR code to be scanned by my phone to link it to the below folder.

    - /srv/dev-disk-by-label-Hippo/Music/TestSync:/sync
  • Check “settings” -> “identity” -> “Link device”

    hi morlan - as usual I am terrible at explaining myself. Yes I can see that on my phone in that its eithers ask for a key/scan to be sent or received.

    but its when I go to <ip address>:8888 which is my test server and go to the same settings, I dont get that option. It just has my identity which I had to create (tannaroo) and upgrade to pro version (i'm not using the pro version). I do not get the same option to link device

  • Are the server and the phone booth listed under my devices in the identities tab?

    No but that is what I'm trying to figure out because the server does not give me an option for a key code or scan code, so that I can link it with my phone.

    EDIT: Just checked again, so when I go to identities on the server, the option is unlink tannaroo or upgrade to pro. but on my android, the same area has my devices which is blank - it waiting for a link code. So I need the code from the server which I cannot generate

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!