portainer: how to update to latest version

  • $ ping google.com -c 4

    PING google.com (172.217.16.142) 56(84) bytes of data.

    64 bytes from fra15s46-in-f14.1e100.net (172.217.16.142): icmp_seq=1 ttl=117 time=8.17 ms

    64 bytes from fra15s46-in-f14.1e100.net (172.217.16.142): icmp_seq=2 ttl=117 time=7.51 ms

    DNS issue is solved.

  • It probably called for a new IP address from your router.


    Log in to your router and see if it's got a new IP assigned to your NAS.. if so, log in to the webUI/SSH with the new IP. If you want to change it back to the old one, we can address that then.

    Put back the PIserver in the router to DHCP first, because it was set static. Run sudo omv-firstaid, and checked new IP. Just log in with SSH to the new IP

    What to do to set it back to the old one, or do I need first need to do something else?

  • Put back the PIserver in the router to DHCP first, because it was set static. Run sudo omv-firstaid, and checked new IP. Just log in with SSH to the new IP

    What to do to set it back to the old one, or do I need first need to do something else?

    OK, so make sure you're back online, you probably are but just to be safe (like I said, you were when you posted that output a minute ago, I was asking a question because you got a permission denied).


    Code
    ping google.com -c4
  • OK, so make sure you're back online, you probably are but just to be safe (like I said, you were when you posted that output a minute ago, I was asking a question because you got a permission denied).


    Code
    ping google.com -c4

    After the error permission denied I did what Macom asked


    sudo systemctl enable systemd-resolved.service

    sudo systemctl start systemd-resolved.service


    und dann nochmal ping google.com -c 4

    And reported what happend


    And than I did again what you asked to do with sudo omv-firstaid, which results now to that PIserver got a new DHCP IP


    $ ping google.com -c4

    PING google.com (142.250.179.142) 56(84) bytes of data.

    64 bytes from ams17s10-in-f14.1e100.net (142.250.179.142): icmp_seq=1 ttl=120 time=2.06 ms

    64 bytes from ams17s10-in-f14.1e100.net (142.250.179.142): icmp_seq=2 ttl=120 time=1.28 ms

    64 bytes from ams17s10-in-f14.1e100.net (142.250.179.142): icmp_seq=3 ttl=120 time=1.26 ms

    64 bytes from ams17s10-in-f14.1e100.net (142.250.179.142): icmp_seq=4 ttl=120 time=1.29 ms


    --- google.com ping statistics ---

    4 packets transmitted, 4 received, 0% packet loss, time 3005ms

    rtt min/avg/max/mdev = 1.256/1.471/2.063/0.341 ms



    Do I need first update portainer to test also the DNS ok

  • DNS is ok now. You can update portainer. Should work now.

    Shoot me, because I have no idea what or why it was wrong?


    Ok Portainer update to version 2.11 DNS ok


    What to do to set Piserver back to the static IP as before. I did this in my Fritxbox, but do I need to do this as well in OMV somewhere?

  • if you did it on the fritzbox. you are are.

    From the point of omv it is still dynamic, only that the fritzbox allways assigns the same ip.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Shoot me, because I have no idea what or why it was wrong?


    Ok Portainer update to version 2.11 DNS ok


    What to do to set Piserver back to the static IP as before. I did this in my Fritxbox, but do I need to do this as well in OMV somewhere?

    I don't mess w/ Fritzbox's (just see them mentioned a lot here)... You don't *have* to do it to your OMV, but if you want it back at the same IP you had before.. then you could set it as static. (the below assumes you've not done something like try to assign the IP in the router)


    In the webUI, go to Network/Interfaces/Edit your current interface...


    Change it to Static..

    Address: This is the IP you want OMV to use


    Netmask: This should be in your router


    If you don't know or can't find it.. you can use the command...


    Code
    ifconfig

    (if you get command not found, sudo apt update then sudo apt install net-tools and run again)


    Go through the output and find your IP address.. it will look something like this

    Code
    enp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.1.166  netmask 255.255.255.0  broadcast 192.168.1.255
            ether 68:05:ca:2b:de:1c  txqueuelen 1000  (Ethernet)
            RX packets 447211  bytes 246732089 (235.3 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 808587  bytes 827587224 (789.2 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 16  memory 0xf7cc0000-f7ce0000  

    Gateway, is usually your router IP, but you can double check it with the command

    Code
    ip r

    You'll probably get several lines, but this is the important one..

    Code
    root@openmediavault:~# ip r
    default via 192.168.1.1 dev enp1s0 proto static 

    Then scroll down and set your DNS servers. Remember no spaces. Just commas and periods.


    Would look something like this

    Code
    1.1.1.1,2.2.2.2

    Then save and after a minute it will time out. You should now be able to log back in to the webUI/SSH at the desired IP.

  • Fitzbox is the router. As long as the settings are like this:


    it is ok. Instead of opnSense it should be your OMV-server in your case.

    This will give you DNS resolution for the name too.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Fitzbox is the router. As long as the settings are like this:


    it is ok. Instead of opnSense it should be your OMV-server in your case.

    This will give you DNS resolution for the name too.

    Ok did what KM0201 explained and put the settings within OMV


    Do I need to do this also within the Fritzbox, or is it enough to do only with OMV?

  • If you set an static IP in OMV you have to make sure the same IP is not assigned to a different device by the router (fritzbox).

    I allways recommend to use your router for the stuff it can do very well (at least for home users). If you stick with static IPs for your OMV:


    Log into your fritzbox

    Go to Heimnetz > Netzwerk > Netzwerkeinstellungen
    Scroll down until you see IP-Adressen

    Click on IPv4 Einstellungen


    Adjust lower / upper bound of DHCP IP Adress range as required (I do not have default settings in my router, so you network may be different)


    Now you can couus a static IP for your server which is

    • outside the range defined here, but
    • within your network and
    • not the IP of your router or
    • not the IP of another devices with fixed IP

    In my case I coud choose an IP from 192.168.7.2 to 192.168.7.19 or 192.168.7.201 to 192.168.7.254


    And keep a list of static IP addresses already assigned in your network or you will get into trouble sooner or later.


    And in case you change your network / netmask or move the server to a different network (the 192.168.7.x netmask 255.255.255.0) switch your servers back to dynamic IPs before doing so or you will have to attach keyboard monitor, ...



    Static IPs should be used only if you have a DNS server, where you can add an entry for that server so you can talk to them by their name, not their IP.


    IPv6 is a different kind of beast, I am not going to cover here.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • And may I asked why there red arrow on resolv.conf?

    It is a symbolic link, not a file, and whatever you used to display it shows it that way.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!