What do I do with docker?

  • ok, so I have docker installed, portainer, yacht, and cockpit. What do I do now? Portainer just seems to be more configuring crap. I want to pull in a image. How do I do that? It was a hell of a lot easier before this new docker setup. Yacht doesn't have anything I want. Github wants some kind of account login but I see no way to create the login. What the hell? Do I need a letter from my mother too? Cockpit wants a login? How do I do that? Jesus this is way too much overkill to just pull some images in.


    • Official Post

    You probably don’t need Cockpit. I have never used it or found any need for it. Cockpit is just a little bit above the need of the average user just wanting to deploy containers. I’m not saying it’s useless but Portainer will do everything you need to get a container up and running.

    That being said, there is a bit of a learning curve with Portainer. Nothing easy is worth much anyway. You might search around this forum for Stacks. It seems to be a real easy way to get a container up and running. If you look at the images on Linuxserver there will docker-compose formatting code you can cut and paste (with some personalizing to suit your situation) into Stacks. You can deploy a docker container without even breaking a sweat. Start with an easy one like Heimdall, which sets up a home page on which you can place buttons to favorite links.

    You can also look through the Guides section of this forum. Look for “docker-compose”.

    If you run into problems, there are lots of friendly folks here who will be happy to help.

    Blessings brother.

    System Backup Typo alert: Under the Linux section the command should be sudo umount /dev/sda1 NOT sudo unmount /dev/sda1

    Backup Data Disk to Backup Disk on Same Machine: In a Scheduled Job:rsync -av --delete /srv/dev-disk-by-uuid-f8814ed9-9a5c-4e1c-8830-426968c20ea3/ /srv/dev-disk-by-uuid-e67439d5-00a3-4942-bd5f-b84ab86aa850/ Don't forget trailing slashes, and BE CAREFUL. (HT: Getting Started with OMV5)

    Equipment - Thinkserver TS140, NanoPi M4 (v.1), Odroid XU4 (Using DietPi): PiHole

  • ok, so I have docker installed, portainer, yacht, and cockpit. What do I do now?

    You could try reading the documentation that comes with every quality and viable docker image and just forget about portainer, yacht, and cockpit. I didn't use any of those to deploy the more than one dozen containers I have running here. Everything I needed to get my containers up and running was provided in their documentations.

    Google is your friend and Bob's your uncle!

    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • ok, so I have docker installed, portainer, yacht, and cockpit. What do I do now? Portainer just seems to be more configuring crap. I want to pull in a image. How do I do that? It was a hell of a lot easier before this new docker setup. Yacht doesn't have anything I want. Github wants some kind of account login but I see no way to create the login. What the hell? Do I need a letter from my mother too? Cockpit wants a login? How do I do that? Jesus this is way too much overkill to just pull some images in.


    uninstal yatch and cockpit, until you know how to use it, learn about portainer, it's really easy to start a container, read my sinature for OMV5 containers, a good start point is PLEX a really easy docker to install on portainer.

    a good start point is to read OMV + Docker plugin media server (Plex, PlexPy, Ombi, Libresonic, NZBGet, ruTorrent, Sonarr, Radarr, Mylar, and more) so you can understand why need to first create user & groups for dockers.

  • ok, so I cheeseballed figuring it out by using the linuxserver addy and then just stuffing that into portainer to find something. So I did follow the Nextcloud/swag guide and got that to work locally, but not with https.

    My nextcloud config.php does not have the following:

    'dbname' => 'nextcloud',

    'dbhost' => 'nextclouddb',

    'dbport' => '',

    'dbtableprefix' => 'oc_',

    'mysql.utf8mb4' => true,

    'dbuser' => 'oc_admin',

    'dbpassword' => 'YfPeqGJ8LlsOIkXpgiEtf3bejjLtUK',

    Also I have some dig results to help with my sanity:

    Dig results

    fun1sys.duckdns.org. 59 IN A

    fun1sys.duckdns.org. 59 IN TXT ""

    fun1sys.duckdns.org. 599 IN MX 50 fun1sys.duckdns.org.

    CNAME is blank

    I did setup forwarding in my router with the guides 457, and 91

    80 and 443 are set to external on the router.

    any thoughts


  • Quote

    any thoughts

    yes, start with something easy, nextcloud is for expert

    My suggest, start with swag only

    eg, change path and UID & GUI to adapt to your needs.

  • is there anyway to use something easier than the UUID for mount points? These entries in /etc/fstab are killing me.

    filesystem mount point

    /dev/disk/by-uuid/a5ace7d5-5952-4205-a5d4-7408637605c9 /srv/dev-disk-by-uuid-a5ace7d5-5952-4205-a5d4-7408637605c9

    When I try to associate something sane like /srv/docker as the mount point then I cannot access it when trying to use it as a shared folder. Then insanely long mount point works but holy cow...


  • looking at your swag config file ...

    do I need this line?

    - MAXMINDDB_LICENSE_KEY=xxxxXXXCccccc #Maxmind.com GeoIp database Key user mymail@gmail.com Pass= X

    I have no idea what that is.

    no if you do not have a valid and free license of GEOIP, you can # it

    eg: #  - MAXMINDDB_LICENSE_KEY=xxxxXXXCccccc  #Maxmind.com GeoIp database Key user mymail@gmail.com Pass= XxxxxxxxxxxX
    • Official Post

    is there anyway to use something easier than the UUID for mount points?

    Yes. Create symlinks. There is a plugin for that or from command line.


    Regarding Portainer:



  • ok here is the error i'm getting just with swag;

    Using Let's Encrypt as the cert provider

    SUBDOMAINS entered, processing

    SUBDOMAINS entered, processing

    Only subdomains, no URL in cert

    Sub-domains processed are: -d fun1sys.duckdns.org

    E-mail address entered: doogleaelf@yahoo.com

    http validation is selected

    Different validation parameters entered than what was used before. Revoking and deleting existing certificate, and an updated one will be created

    nerating new certificate

    Saving debug log to /var/log/letsencrypt/letsencrypt.log

    Plugins selected: Authenticator standalone, Installer None

    Account registered.

    Requesting a certificate for fun1sys.duckdns.org

    Performing the following challenges:

    http-01 challenge for fun1sys.duckdns.org

    Waiting for verification...

    Challenge failed for domain fun1sys.duckdns.org

    http-01 challenge for fun1sys.duckdns.org

    Cleaning up challenges

    Some challenges have failed.


    - The following errors were reported by the server:

    Domain: fun1sys.duckdns.org

    Type: connection

    Detail: Fetching


    Timeout during connect (likely firewall problem)

    ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

    And here is my docker-compose file:

    version: '2.1'



    image: linuxserver/swag

    container_name: swag




    - PUID=1000

    - PGID=100

    - TZ=America/Chicago

    - URL=duckdns.org

    - SUBDOMAINS=fun1sys

    - VALIDATION=http

    # - DNSPLUGIN=cloudflare #optional

    - DUCKDNSTOKEN=92908fbe-fa0d-4160-89a8-17199d4c0fc0

    - EMAIL=doogleaelf@yahoo.com #optional

    - DHLEVEL=2048 #optional

    - ONLY_SUBDOMAINS=true #optional

    - STAGING=false #optional


    - /srv/dev-disk-by-uuid-a5ace7d5-5952-4205-a5d4-7408637605c9/app/swag:/config # please use your own path


    - 457:443

    - 91:80 #optional

    restart: unless-stopped

    And the router

  • I do use the stack part of portainer to compose the configs. It is actually fairly handy. I went thru the portainer docs and setup users, groups, teams .... all that malarkey. Then I went and deleted it all (yacht, that qemu thing, and portainer). Deleted all my remote shares, shared folders and samba shares, cleaned up the /srv folder and /etc/fstab. Had to fix where docker was storing my images (get em off the system partition and on to the data partition. Got all that done, recreated the remote and shared folders, created the CIFS share using dockeruser for user and dockergroup for group for all the permissions(shared folder uses the same).

    and now I have the swag issue. I may just play with something that doesn't need a cert to work.

  • first to use sawg you need to create docker duckdns so this docker must work and point to your NAS IP.

    in your router redirect port 80 to port 80 of your NAS IP , and try to connect to http://fun1sys.duckdns.org if your OMV WEBGUI is show, all is good and your swag must work, otherwise, you need to revise your duckDNS Accont first to be sure that point to your public IP. (once you test that redirect works, you can restore port 80 -> 91 , like are write on your swag stack.

    eg: acording your provided info

    so you only need to copy & paste in the stack section and deploy.

    once this works and update your public IP , you can deploy the sawg stack, but comment (#) lines refer to duckdns, because you have a working docker that do the job

  • Changing the router forward to 80:80 and going to http://fun1sys.duckdns.org worked fine. I even turned off the wireless on my phone and it worked fine from that too.

    Well I'm confused as to what part of the swag stack "refers" to duck dns?


    I just commented out

    # - DUCKDNSTOKEN=92908fbe-fa0d-4160-89a8-17199d4c0fc0

    and that is it.

    I have to use the full /srv/dev-disk-by-uuid-a5ace7d5-5952-4205-a5d4-7408637605c9/app/<whatever app> or else it doesn't show up on my cifs share.

  • ok I commented out the following two lines

    # - DUCKDNSTOKEN=92908fbe-fa0d-4160-89a8-17199d4c0fc0

    # - SUBDOMAINS=fun1sys

    changed URL= fun1sys.duckdns.org from duckdns.org

    and that appeared to work....... I think.....

    swag log follows:

    is that just some old log stuff at the end?

  • yes it did work. Thanx for your patience.

    Now on to Storm er nextcloud.

    I cannot get the mariadb to connect. I keep getting connection refused when I get to the add admin user/setup db page. It has worked using sqlite ... but then that is too easy ;). I have been using KM0201's nextcloud docker config file (Nextcloud Bad Gateway - General - openmediavault) but no matter how many different ways I tweak it I cannot complete the db connection.

    At one point I was having permission issues with the CIFS share. I checked my Shared Folders and there was an issue of changing the user and group and owner of the shared folder. I would change it... then go back and it did not take. And yes I was checking the recursive check box. It did finally take after time. Maybe it just an hysteresis issue with all this stuff proprogating out to the drive. It sure beats me. It all does seem to finally work ok now. I no longer have to wait 10 minutes for permissions to get changed on 20K+ files. I will hunt and peck around for another nextcloud docker config file. Does mariadb have to "married" to nextcloud or can you use a seperate config for that. It would be nice if I could test the damn thing before even messing with stormcloud.

    Anyway thanx everyone for your help!!!!!

  • Here is where I'm at now. I can get Swag to generate a certificate without errors. When I try to use nextcloud over the internet. It complains about the certificate being invalid. I'm using duckdns, and it appears to me that not being able to set a CNAME record is causing issues. When I comment out the port 450 in the nextcoud config file, I cannot get to nextcloud without a certificate error. This is using my phone with the wireless disabled so as to be on the internet side of things.

    I'm using port 457:443 for swag and 450:443 for nextcloud. I have tried all combintions of tweaking these ports. ie: setting both to 443 and just forwarding to my omv ip, setting both to 450 or 457 etc .... The best I can get is I can put in http://www.nextcloud.fun1sys.org and lo and behold it pulls up a swag documentation page without a certificate error! Not real exciting. In the swag docs it says something about using cloudfare because it's free. Well it doesn't look like having your own domain is free so that appears to be a bust. Cloudfare will point to a existing domain, but doesn't look like it will set you up with one(for free anyway).

    Some successes I've had are: I've been able to create 3 separate docker containers for swag, nextcloud and nextclouddb, and get them all to use a network that I defined called omv. They even show up in poortainer as containers using the omv network.

    I did this the hard way using docker create and entering each line separately in the shell. It was the only way I could get them all on the same created network, omv, as poortainer just won't let you do that. I guess I'm confused as to how swag and nextcloud can both use port 443 but yet I'm forwarding them to different ports in my router. Does the router just forward everything to both 450 and 457 and not care?


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!