Shared Folders permission issues

  • Hi team,


    I recently installed OMV 6 on an HP Proliant G7 ML110. I attempted this last year with OMV 5 but had so many issues, I gave up on it (well, I didn't have time really).

    Have come across an issue regarding sharing permissions which I'm unable to make much sense of it, even when following different how-to videos and documentation:


    To get me started, I'm trying to get a public folder to be accessible on the network (testing with W10): on the Web GUI, Under Storage>>Shared Folders, when I opt for Everyone: read/write and save it (as well as saving the configuation changes) it reverts back to Administrator: read/wite, Users: read/write, Others: read-only.


    Any ideas?


    Secondly, I'm promped with login credentials but unfortunalty it won't accept the password. I have set a new user under User Management>>Users. Still, it dosn't like it.


    Any help would be appreciated it.


    Thanks.

    1. You do realize that OMV6 is not intended for general use at this time. An alpha release means it is being debugged and is not reliable for general use. You are better off going back to OMV5 if you want a production ready server without bugs.
    2. To be able to view shares on your PC you need to create SMB shares of your Shared Folders. Look under Services for the SMB/CIFS tab.

    Simple and sure backup and restore: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    Server Software: OMV 5 (current) - My Main Server: Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, & Heimdall - My Backup Machine: NanoPi M4 (v.1), Pi-Hole - Odroid XU4 (Using DietPi) - Testing/Playing: hc2, xu4, Pi 3B+, Odroid H2. Mac user converting to Linux, Debian 10 KDE.

  • Secondly, I'm promped with login credentials but unfortunalty it won't accept the password. I have set a new user under User Management>>Users. Still, it dosn't like it.

    The default credentials for the GUI are admin/openmediavault.

    The user "admin" is the default user to use the GUI. Stick with it.


    You should really use OMV5 at the moment to avoid frustration.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!