NFS share not automatically mounting

  • I'm on the outskirts of an OMV question here, don't crucify me. I know there's something I'm forgetting here. I seem to recall I had to do something on my last laptop to resolve this but I can't remember what I done. What I think is happening, is nfs is starting before my wireless connection is up... so after I log in, my nfs shares are not mounted. I run mount -a, and my nfs shares are immediately available... so my fstab and nfs-server appear to be working just fine, and unfortunately Google isn't turning up a solution.


    Any suggestion would be appreciated.


    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Easy data backup: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, Wetty, & Heimdall - NanoPi M4 (v.1): backups using Rsync and Rsnapshot - Odroid XU4 (Using DietPi): PiHole - hc2, xu4, Pi 3B+, Odroid H2, and VirtualBox: Testing and playing - Mac user converting to Linux, Debian 10 KDE.

  • I'm on the outskirts of an OMV question here, don't crucify me. I know there's something I'm forgetting here. I seem to recall I had to do something on my last laptop to resolve this but I can't remember what I done. What I think is happening, is nfs is starting before my wireless connection is up... so after I log in, my nfs shares are not mounted. I run mount -a, and my nfs shares are immediately available... so my fstab and nfs-server appear to be working just fine, and unfortunately Google isn't turning up a solution.


    Any suggestion would be appreciated.


    I would change/modify your entry with this "nfs rw,auto,hard,nofail,intr 0 0". It works on my system.

    Edit: one more thing my mount is in /media/nfs, if that make any difference.

    EndeavourOS

    Linux Mint 20.2 "Uma", Cinnamon DT

    OMV5 NAS, 20TB storage

    Edited once, last by andrzejls: adding additional info ().

  • I would change/modify your entry with this "nfs rw,auto,hard,nofail,intr 0 0". It works on my system.

    Edit: one more thing my mount is in /media/nfs, if that make any difference.

    The mount points shouldn't matter... I don't think I've ever mounted anything under /media (usually use /mnt, /mnt1, /mnt2, etc.)


    from the mount man page


    It doesn't look like nofail has anything to do with it, just from the man page... I can't even find your other entries, so I'm not sure what they do... that said, adding hard and intr did work.


    It's not what I done last time... but it's working.


    Edit: Well, I spoke to soon, it didn't survive a second reboot?


    Thanks

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • You are absolutely right that std. mount point would be /mnt, /mnt1, mnt2...etc if you have local drive, if I am correct. I used this mount point (/media/nfs) and these settings since this is an external drive attached to USB 3.0 port on my main router (Asus RT-AC1900P) and I used export nfs option. Could not mount this drive using cifs. All my other OMV shares (12 in total) are mounted on my laptop as "cifs in fstab. As you recognized "rw" is for "read/write", "auto" is self explanatory. As I said, it works on my Linux Mint Cinnamon laptop. He might have an another setup/consideration.


    EDIT: on my OMV5 NAS server one of my mount (example) is :/dev/disk/by-label/Files2 /srv/dev-disk-by-label-Files2 btrfs defaults,nofail 0 2

    EndeavourOS

    Linux Mint 20.2 "Uma", Cinnamon DT

    OMV5 NAS, 20TB storage

    Edited once, last by andrzejls ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!